Refund Timeout Error
Incident Report for Upscribe
Resolved
This incident has been resolved.
Posted Sep 16, 2022 - 08:28 PDT
Investigating
We are aware of an issue in admin where refund requests are timing out. We are currently investigating this issue.
Posted Sep 16, 2022 - 06:59 PDT
This incident affected: Websites (Admin Portal).